21 lines
512 B
Nix
21 lines
512 B
Nix
{ modulesPath, ... }: {
|
|
imports = [ (modulesPath + "/profiles/qemu-guest.nix") ./generic-grub.nix ];
|
|
|
|
boot.loader.grub.device = "/dev/sda";
|
|
|
|
boot.initrd.availableKernelModules =
|
|
[ "ata_piix" "uhci_hcd" "virtio_pci" "sr_mod" "virtio_blk" ];
|
|
boot.initrd.kernelModules = [ ];
|
|
boot.kernelModules = [ "kvm-intel" ];
|
|
boot.extraModulePackages = [ ];
|
|
|
|
boot.kernelParams = [
|
|
"console=tty1"
|
|
"console=ttyS0,115200"
|
|
];
|
|
|
|
fileSystems."/" = {
|
|
device = "/dev/vda1";
|
|
fsType = "ext4";
|
|
};
|
|
}
|