27 lines
591 B
Nix
27 lines
591 B
Nix
{
|
|
inputs = {
|
|
nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
|
|
flake-utils.url = "github:numtide/flake-utils";
|
|
};
|
|
|
|
outputs = { self, nixpkgs, flake-utils }:
|
|
flake-utils.lib.eachDefaultSystem(system:
|
|
let
|
|
pkgs = import nixpkgs {
|
|
inherit system;
|
|
};
|
|
inherit (pkgs) lib;
|
|
in
|
|
{
|
|
devShells.default = pkgs.mkShell {
|
|
nativeBuildInputs = with pkgs; [
|
|
(python311.withPackages(ps: [
|
|
ps.pydub
|
|
]))
|
|
ffmpeg_6
|
|
mpv
|
|
];
|
|
};
|
|
}
|
|
);
|
|
}
|